summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2023-04-24 12:53:34 +0200
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2023-04-25 11:08:29 +0200
commit27e1451891db22067f569c60065a7ee1091a6993 (patch)
treeb49a7f2e4e6aeb25f522798635a3e5c6e2e7a376
parentffb7ea6b630717072bd29eb16195a2bae85d5498 (diff)
gnu: python-trio: Downgrade to 0.21.
Version 0.22 deprecates MultiError, which trips up testsuites of dependents. python-anyio for instance is explicitly not compatible with >= 0.22, so stick to an older release. * gnu/packages/python-xyz.scm (python-trio): Downgrade to 0.21. [arguments]: Disable failing test.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dd1b4a64f2..95898c31da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24837,13 +24837,13 @@ project.")
(define-public python-trio
(package
(name "python-trio")
- (version "0.22.0")
+ (version "0.21.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trio" version))
(sha256
- (base32 "1kxa9v0cds0xnklvzppv4ix4xg81r73p5pm4qlvv2iqa832z2s6f"))))
+ (base32 "04qwzy4295ajxpns0hrmn3asma80sjpimzpb3i877vwynsvkjgsj"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -24876,6 +24876,8 @@ _cyclic_garbage"
" and not test_locals_destroyed_promptly_on_cancel"
" and not test_ipython_exc_handler"
" and not test_for_leaking_fds"
+ ;; Signals don’t work in the build sandbox.
+ " and not test_open_signal_receiver"
;; These try to raise KeyboardInterrupt which does not work
;; in the build environment.
" and not test_ki_self"