summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Henry Fröhring <phfrohring@deeplinks.com>2023-12-10 14:04:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-17 22:22:31 +0100
commitab74b47e92fd88ebcef20cec2600d690a6061c23 (patch)
tree68b93b570d997db1803c61aacdac5f6c6379fd3c
parent20312bdf5bb4b68f4b652e024471d9c31cf14d34 (diff)
gnu: Add elixir-castore.
* gnu/packages/elixir-xyz.scm (elixir-castore): New variable. Change-Id: Iea1fea8241d19ff35a183af9c3fbf2ed5198a259 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/elixir-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index ed61cac508..ef80c9550c 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -164,6 +164,24 @@ inline docs.")
(home-page "https://hex.pm/packages/inch_ex")
(license license:expat)))
+(define-public elixir-castore
+ (package
+ (name "elixir-castore")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri name version))
+ (sha256
+ (base32 "1y44amb8falsmrfzpkmf7qp6215g9kdl76g91dpna4af2jwc264l"))))
+ (build-system mix-build-system)
+ (arguments (list #:tests? #f)) ; no tests
+ (synopsis "Up-to-date CA certificate store")
+ (description "The Elixir castore package is a micro-library that provides
+an up-to-date CA certificate store file for Elixir applications.")
+ (home-page "https://hexdocs.pm/castore/")
+ (license license:asl2.0)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar