summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-25 11:32:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-25 11:32:10 +0200
commitce0bdceb4948d5f297327a1b1724074ca960eb05 (patch)
tree21c810a43715f2ac9c284b28347600cbab7b11c3
parent8495069bed0d51a21ff609f7036ff40d73ff07a8 (diff)
gnu: python-importlib-resources: Update to 5.12.0.
* gnu/packages/python-xyz.scm (python-importlib-resources): Update to 5.12.0. [build-system]: Use pyproject-build-system. [arguments]: Add phase to avoid "pip install". [native-inputs]: Remove python-toml; add python-flake8, python-pytest, python-pytest-black, python-pytest-checkdocs, python-pytest-cov, python-pytest-enabler, python-pytest-flake8, python-pytest-mypy, and python-setuptools-57. [propagated-inputs]: Add python-zipp.
-rw-r--r--gnu/packages/python-xyz.scm46
1 files changed, 42 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 856fc9adb9..232a56ad43 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8932,15 +8932,53 @@ older Python versions.")
(define-public python-importlib-resources
(package
(name "python-importlib-resources")
- (version "3.0.0")
+ (version "5.12.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "importlib_resources" version))
(sha256
(base32
- "1hq626mx5jl9zfl0wdrjkxsnh8qd98fqv322n68b9251xjk4bxqr"))))
- (build-system python-build-system)
- (native-inputs (list python-setuptools-scm python-toml))
+ "1xi2ggdfdj1bg7w728lvy6j3rjqhklalaanzmscpj7awpy4jbs2b"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ ;; The build system insists on ignoring the existing environment and
+ ;; running "pip install".
+ (add-after 'unpack 'do-not-use-pip-install
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("^build-backend.*") "\
+build-backend = \"backend\"
+backend_path = [\"_custom_build\"]\n")
+ (("requires = .*") "requires = []\n"))
+ (mkdir-p "_custom_build")
+ (with-output-to-file "_custom_build/backend.py"
+ (lambda _
+ (display "\
+from setuptools import build_meta as _orig
+from setuptools.build_meta import *
+def get_requires_for_build_wheel(config_settings=None):
+ return []
+def get_requires_for_build_sdist(config_settings=None):
+ return []
+")))
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) "/_custom_build")))))))
+ (native-inputs
+ (list python-flake8
+ python-pytest
+ python-pytest-black
+ python-pytest-checkdocs
+ python-pytest-cov
+ python-pytest-enabler
+ python-pytest-flake8
+ python-pytest-mypy
+ python-setuptools-57
+ python-setuptools-scm))
+ (propagated-inputs
+ (list python-zipp))
(home-page "https://importlib-resources.readthedocs.io/")
(synopsis "Read resources from Python packages")
(description