summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-30 18:22:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-05 00:12:46 +0200
commitf454a2781b63ce89c54a5c8df99b730f96d8e870 (patch)
tree87248174b90836a4314316037e9ec44fbdc8b638
parent7c4546d591cac73a34cee5a519222904315731a9 (diff)
gnu: rav1e: Patch Cargo.toml.
* gnu/packages/video.scm (rav1e)[source]: Patch Cargo.toml to enable feature needed to parse the file.
-rw-r--r--gnu/packages/video.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 942d158afa..e8735e4997 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5209,7 +5209,12 @@ result in several formats:
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "006bfcmjwg0phg8gc25b1sl2ngjrb2bh1b3fd0s5gbf9nlkr8qsn"))))
+ "006bfcmjwg0phg8gc25b1sl2ngjrb2bh1b3fd0s5gbf9nlkr8qsn"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "Cargo.toml"
+ (("\\[package\\]" m)
+ (string-append "cargo-features = [\"rust-version\"]\n" m))))))
(build-system cargo-build-system)
(arguments
`(;; Strip the '--release' flag to work around the doctest failures with