summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-12 20:24:58 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 09:50:06 +0200
commit2e198540300127397bbf16228a811fd962ccdd54 (patch)
treef00c3d1fc9085916121603e39e6f1c99abd291c8
parent468e3604e482388204e58662c20ba51c986f07a6 (diff)
gnu: Add emacs-transient-posframe.
* gnu/packages/emacs-xyz.scm (emacs-transient-posframe): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c8ecdebe2..5c76202d21 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37553,6 +37553,32 @@ a Vertico extension which provides a way to pop up a frame at point to show
a vertical completion UI.")
(license license:gpl3+)))
+;; No tagged release upstream
+(define-public emacs-transient-posframe
+ (let ((commit "dcd898d1d35183a7d4f2c8f0ebcb43b4f8e70ebe")
+ (revision "0"))
+ (package
+ (name "emacs-transient-posframe")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yanghaoxie/transient-posframe")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1aq1vbkww55xplyaa3xagz9z4kdlsxk13x054asnk0dqps4bcgbf"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-posframe emacs-transient))
+ (home-page "https://github.com/yanghaoxie/transient-posframe")
+ (synopsis "Pop up a posframe (a child frame) to show Transients")
+ (description
+ "This package is a @code{transient} extension, which uses @code{posframe}
+(a child frame) to show @code{transient} popups in Emacs. It was developed with
+@code{transient} popups of @code{magit} in mind.")
+ (license license:gpl3+))))
+
(define-public emacs-tintin-mode
(let ((commit "82e71e1db92ee3d94c7d0208bafc5de337193de8")
(revision "1"))