summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-14 23:32:57 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 09:50:06 +0200
commit440ce641cc0b6e7f64e2b087222c5d47ce8c597e (patch)
tree81557a64e0a909fec257857b0137e7f5de19b47a
parent4b83e94bd83c96da027df313e9e585c943101ffd (diff)
gnu: Add emacs-persistent-scratch.
* gnu/packages/emacs-xyz.scm (emacs-persistent-scratch): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6c32f4140a..1d1c11ba75 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34622,6 +34622,27 @@ one file per value. This makes it easy to delete or remove unused
variables.")
(license license:gpl3+)))
+(define-public emacs-persistent-scratch
+ (package
+ (name "emacs-persistent-scratch")
+ (version "0.3.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Fanael/persistent-scratch")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "187cyl005csmmmh292km1v3ffl8x49h5qyn87i4adz9l5sqnpdgj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Fanael/persistent-scratch")
+ (synopsis "Preserve the scratch buffer across Emacs sessions")
+ (description
+ "Preserve the state of scratch buffers across Emacs sessions by saving the
+state to and restoring it from a file, with auto-saving and backups.")
+ (license license:bsd-2)))
+
(define-public emacs-company-emoji
(package
(name "emacs-company-emoji")