summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-14 22:48:05 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 09:50:06 +0200
commit68945743c2c67cce6129eb1014bccd1172abec04 (patch)
tree9ebd414640173cdfb83fd0f91aa5ba8f38dc6774
parentd41d60b6089a3539971355705177413a2ecea319 (diff)
gnu: Add emacs-exotica-theme.
* gnu/packages/emacs-xyz.scm (emacs-exotica-theme): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e5c7436d0d..8c929862b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17593,6 +17593,31 @@ DefaultEncrypt, please refer to the home page or read the comments in the
source file, @file{jl-encrypt.el}.")
(license license:gpl3+)))
+;; Package has no release. Version is extracted from "Version:" keyword in
+;; main file.
+(define-public emacs-exotica-theme
+ (let ((commit "ff3ef4f6fa38c93b99becad977c7810c990a4d2f")
+ (revision "0"))
+ (package
+ (name "emacs-exotica-theme")
+ (version (git-version "1.0.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zenobht/exotica-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kp6q55g3dcya4y79x877vqwxa4z2rkkvhs49pkwr3wljf4af2pd"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/zenobht/exotica-theme")
+ (synopsis "Dark theme for Emacs with vibrant colors")
+ (description
+ "A dark opinionated theme with vibrant colors for Emacs. Inspired by
+@code{Molokai} and @code{Dracula} themes.")
+ (license license:gpl3+))))
+
(define-public emacs-extend-smime
(package
(name "emacs-extend-smime")