summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-22 07:53:29 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 09:50:07 +0200
commit6ac90e894212a30f7d9bdc1acff90663916781ee (patch)
tree668e7d9a6683ddef8b96eeed24caae561503caa8
parent4423298863933e1a497ba591ce64392223d61319 (diff)
gnu: Remove queen.
This package, along with other SCUMMVM-based games violate the FSDG: they are neither built from nor point towards their corresponding source code. See <https://lists.gnu.org/archive/html/guix-devel/2022-08/msg00039.html> and <https://lists.gnu.org/archive/html/guix-devel/2023-06/msg00091.html> for more information. * gnu/packages/games.scm (make-queen-package, queen, queen-de, queen-fr) (queen-it): Delete variable.
-rw-r--r--gnu/packages/games.scm94
1 files changed, 0 insertions, 94 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 26e9b35526..1794f6afbd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9724,100 +9724,6 @@ the game avoids complex inventory management and character building, relying
on items and player adaptability for character progression.")
(license license:isc)))
-(define (make-queen-package name file-prefix release language hash)
- (package
- (name name)
- (version release)
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/scummvm/extras/"
- "Flight%20of%20the%20Amazon%20Queen/"
- file-prefix release ".zip"))
- (sha256
- (base32 hash))))
- (build-system copy-build-system)
- (arguments
- (list
- #:install-plan
- #~'(("queen.1c" #$(string-append "share/" name "/"))
- (#$name "bin/")
- (#$(string-append name ".desktop") "share/applications/")
- ("." #$(string-append "share/doc/" name "-" version)
- #:include-regexp ("README" "readme")))
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'install 'build
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (with-output-to-file #$name
- (lambda ()
- (format #t "#!~a~%" (search-input-file inputs "bin/sh"))
- (format #t "exec ~a -q ~a -p ~a queen~%"
- (search-input-file inputs "bin/scummvm")
- #$language
- (string-append (assoc-ref outputs "out")
- "/share/" #$name))))
- (chmod #$name #o755)
- (with-output-to-file #$(string-append name ".desktop")
- (lambda ()
- (format
- #t
- "[Desktop Entry]~@
- Name=Flight of the Amazon Queen~@
- GenericName=Queen~@
- Comment=Embark on a quest to rescue a kidnapped princess~
- and in the process, discover the true sinister intentions~
- of a suspiciously located Lederhosen company~@
- Comment[de]=Begib dich auf ein Abenteuer, um eine entführte~
- Prinzessin zu retten und entdecke die wahren, finsteren~
- Absichten eines verdächtig erscheinenden~
- Lederhosen-Unternehmens~@
- Type=Application~@
- Exec=~a~@
- Icon=~a/share/icons/hicolor/scalable/apps/scummvm.svg~@
- Categories=AdventureGame;Game;RolePlaying;~@
- Keywords=adventure;game;roleplaying;fantasy;~%"
- (string-append (assoc-ref outputs "out") "/bin/" #$name)
- (search-input-file inputs "bin/scummvm")))))))))
- (native-inputs (list unzip))
- (inputs (list bash scummvm))
- (home-page "https://www.scummvm.org/")
- (synopsis "Classic 2D point and click adventure game")
- (description "Flight of the Amazon Queen is a 2D point-and-click
-adventure game set in the 1940s.
-
-You assume the role of Joe King, a pilot for hire who is given the job
-of flying Faye Russell (a famous movie star) into the Amazon jungle
-for a photo shoot. Of course, things never go according to plans.
-After an unfortunate turn of events they find themselves stranded in
-the heart of the Amazon jungle, where Joe will embark on a quest to
-rescue a kidnapped princess and in the process, discover the true
-sinister intentions of a suspiciously located Lederhosen company. In
-a rich 2D environment, Joe will cross paths with a variety of unlikely
-jungle inhabitants including, but not limited to, a tribe of Amazon
-women and 6-foot-tall pygmies.")
- (license (license:non-copyleft "file:///readme.txt"))))
-
-(define-public queen
- (make-queen-package
- "queen" "FOTAQ_Talkie-" "1.1" "en"
- "1a6q71q1dl9vvw2qqsxk5h1sv0gaqy6236zr5905w2is01gdsp52"))
-
-(define-public queen-de
- (make-queen-package
- "queen-de" "FOTAQ_Ger_talkie-" "1.0" "de"
- "13vn43x7214vyprlpqabvv71k890nff3d6fjscflr1ll7acjca3f"))
-
-(define-public queen-fr
- (make-queen-package
- "queen-fr" "FOTAQ_Fr_Talkie_" "1.0" "fr"
- "0hq5g4qrkcwm2kn5i4kv4hijs9hi7bw9xl1vrwd1l69qqn30crwy"))
-
-(define-public queen-it
- (make-queen-package
- "queen-it" "FOTAQ_It_Talkie_" "1.0" "it"
- "1h76y70lrpzfjkm53n4nr364nhyka54vbz9r7sadzyzl7c7ilv4d"))
-
(define-public sky
(package
(name "sky")