summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-12 22:43:21 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 09:50:06 +0200
commit9eb37dd1959130c6fa6e27cde6fb7f136bac0a24 (patch)
treec6224bde8a0e44b74d813cbbcd10a95086eadec5
parent2e198540300127397bbf16228a811fd962ccdd54 (diff)
gnu: Add emacs-which-key-posframe.
* gnu/packages/emacs-xyz.scm (emacs-which-key-posframe): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5c76202d21..316ab04900 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19351,6 +19351,34 @@ available key bindings that follow C-x (or as many as space allows given your
settings).")
(license license:gpl3+)))
+;; Tagged release upstream is from before the package was orphaned.
+;; The base version is extracted from the "Version" keyword in the main file
+;; with "-git" suffix removed.
+(define-public emacs-which-key-posframe
+ (let ((commit "e4a9ce9a1b20de550fca51f14d055821980d534a")
+ (revision "0"))
+ (package
+ (name "emacs-which-key-posframe")
+ (version (git-version "0.2.0.50" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/emacsorphanage/which-key-posframe")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kgc29pb5k6cb2m13cz1yhys1k8l4dpx6wjjgldpdlg9qw2i1b53"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-posframe emacs-which-key))
+ (home-page "https://github.com/emacsorphanage/which-key-posframe")
+ (synopsis "Display which-key popup in a posframe (a child frame)")
+ (description
+ "This package is a @code{which-key} extension, which uses posframe
+(a child frame) to show @code{which-key} popups.")
+ (license license:gpl3+))))
+
(define-public emacs-display-wttr
(package
(name "emacs-display-wttr")