summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-07-22 09:26:27 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-07-22 09:26:27 +0200
commitb4a0f6283266cdc681e2f3bc93a558f5dc2a26ea (patch)
tree30789e1f2851084bff08a49d69d296af4bc3b7a1
parent3a05604a57671682943253781ac0d9f637809660 (diff)
gnu: Add soapyairspy.
* gnu/packages/radio.scm (soapyairspy): New variable.
-rw-r--r--gnu/packages/radio.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 7efbc93d7c..fef39996c8 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -400,6 +400,30 @@ with this package. E.g.: @code{(udev-rules-service 'airspyhf airspyhf)}")
defined radio hardware devices with a common API.")
(license license:boost1.0)))
+(define-public soapyairspy
+ (package
+ (name "soapyairspy")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapyAirspy")
+ (commit (string-append "soapy-airspy-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g23yybnmq0pg2m8m7dbhif8lw0hdsmnnjym93fdyxfk5iln7fsc"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list airspy soapysdr))
+ (arguments
+ (list #:tests? #f)) ; No test suite
+ (home-page "https://github.com/pothosware/SoapyAirspy/wiki")
+ (synopsis "SoapySDR Airspy module")
+ (description "This package provides Airspy devices support to the
+SoapySDR library.")
+ (license license:expat)))
+
(define-public soapyairspyhf
(package
(name "soapyairspyhf")