summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:04 +0200
commitfdfea4c4ed0d31494fcb3633c26290f4eba9d2af (patch)
tree3e4ee86fd972c6f138318d4cffd438dac648b6a0
parent448e75ff9b7b605c4d9b7f73258ad31b8bd3904a (diff)
gnu: brltty: Use G-expressions.
* gnu/packages/accessibility.scm (brltty)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/accessibility.scm90
1 files changed, 40 insertions, 50 deletions
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index ef7faedb10..e0a362ae4a 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -103,56 +103,46 @@ terminals.")
(base32 "1z54rin4zhg3294pq47gamzjy2c56zfkl07rx2qy2khlpyczds0k"))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:tests? #f ; No target
-
- ;; High parallelism may cause errors such as:
- ;; ranlib: ./libbrlapi_stubs.a: error reading brlapi_stubs.o: file truncated
- #:parallel-build? #f
-
- #:configure-flags
- (list
- (string-append "--with-libbraille="
- (assoc-ref %build-inputs "libbraille"))
- (string-append "--with-espeak_ng="
- (assoc-ref %build-inputs "espeak-ng"))
- (string-append "--with-espeak="
- (assoc-ref %build-inputs "espeak"))
- (string-append "--with-flite="
- (assoc-ref %build-inputs "flite"))
- ;; Required for RUNPATH validation.
- (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out")
- "/lib"))
- #:make-flags
- (list
- (string-append "JAVA_JAR_DIR="
- (assoc-ref %outputs "out"))
- (string-append "JAVA_JNI_DIR="
- (assoc-ref %outputs "out"))
- (string-append "OCAML_DESTDIR="
- (assoc-ref %outputs "out")
- "/lib")
- (string-append "PYTHON_PREFIX="
- (assoc-ref %outputs "out"))
- "PYTHON_ROOT=/"
- (string-append "TCL_DIR="
- (assoc-ref %outputs "out")
- "/lib")
- "INSTALL_WRITABLE_DIRECTORY=no-thanks")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-errors
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "configure"
- (("/sbin/ldconfig")
- (which "true")))
- ;; Make Python bindings use rpath.
- (substitute* "Bindings/Python/setup.py.in"
- (("extra_compile_args =")
- (string-append "extra_link_args = ['-Wl,-rpath="
- (assoc-ref outputs "out")
- "/lib'], "
- "extra_compile_args = "))))))))
+ (list
+ #:tests? #f ; no target
+ ;; High parallelism may cause errors such as:
+ ;; ranlib: ./libbrlapi_stubs.a: error reading brlapi_stubs.o: file truncated
+ #:parallel-build? #f
+ #:configure-flags
+ #~(list
+ (string-append "--with-libbraille="
+ #$(this-package-input "libbraille"))
+ (string-append "--with-espeak_ng="
+ #$(this-package-input "espeak-ng"))
+ (string-append "--with-espeak="
+ #$(this-package-input "espeak"))
+ (string-append "--with-flite="
+ #$(this-package-input "flite"))
+ ;; Required for RUNPATH validation.
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
+ #:make-flags
+ #~(list
+ (string-append "JAVA_JAR_DIR=" #$output)
+ (string-append "JAVA_JNI_DIR=" #$output)
+ (string-append "OCAML_DESTDIR=" #$output "/lib")
+ (string-append "PYTHON_PREFIX=" #$output)
+ "PYTHON_ROOT=/"
+ (string-append "TCL_DIR=" #$output "/lib")
+ "INSTALL_WRITABLE_DIRECTORY=no-thanks")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-errors
+ (lambda _
+ (substitute* "configure"
+ (("/sbin/ldconfig")
+ (which "true")))
+ ;; Make Python bindings use rpath.
+ (substitute* "Bindings/Python/setup.py.in"
+ (("extra_compile_args =")
+ (string-append "extra_link_args = ['-Wl,-rpath="
+ #$output
+ "/lib'], "
+ "extra_compile_args = "))))))))
(native-inputs
(list clisp
python-cython