summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCaleb Ristvedt <caleb.ristvedt@cune.org>2019-12-13 10:04:21 -0600
committerCaleb Ristvedt <caleb.ristvedt@cune.org>2020-04-13 13:14:51 -0500
commitd1832f8b5cafdccfba99fc615ba932fc69590cf3 (patch)
tree783dc2d7cdc628fd5374d636133cc50e76db2c2f /Makefile.am
parent46e2a65bbf27844bde60d313836e8faad039d6cd (diff)
guix/store/environment.scm: new module
* guix/store/environment.scm (<environment>, environment-{namespaces, variables, temp-dirs, filesystems, new-session?, new-pgroup?, setup-i/o-proc, preserved-fds, chroot, personality, user, group, hostname, domainname}, build-environment-vars, delete-environment, run-in-environment, bind-mount, standard-i/o-setup, %standard-preserved-fds, nonchroot-build-environment, chroot-build-environment, builtin-builder-environment, run-standard, run-standard-build, wait-for-build): new exported variables. * guix/store/database.scm (output-path-id-sql, outputs-exist?, references-sql, file-closure, all-input-output-paths, all-transitive-inputs): new variables. (outputs-exist?, file-closure, all-transitive-inputs): exported. * Makefile.am (STORE_MODULES): add guix/store/environment.scm.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0bce8ac9f1..43a98ad906 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -311,7 +311,8 @@ endif BUILD_DAEMON_OFFLOAD
STORE_MODULES = \
guix/store/database.scm \
guix/store/deduplication.scm \
- guix/store/roots.scm
+ guix/store/roots.scm \
+ guix/store/environment.scm
MODULES += $(STORE_MODULES)