summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-10 00:31:31 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-10 00:35:27 +0200
commita94546ecc46b15d68764a8d3c859315c18010bb4 (patch)
treeb414fc8633a40299316e68cfca18098024988747 /Makefile.am
parented09bb11cdd3454c00caf10615fac3cdd1791d55 (diff)
gnu: linux-libre: Add i686 and x86_64 full-blown configs.
Thanks to Jason Self <jself@gnu.org> for the kernel configs. * gnu/packages/linux.scm (kernel-config): New procedure. (linux-libre)[build-phase]: Copy it to .config. Reduce the list of things appended to .config. [native-inputs]: Add "kconfig" input. * gnu/packages/linux-libre-i686.conf, gnu/packages/linux-libre-x86_64.conf: New files, from <http://jxself.org/x86-32.txt> and <http://jxself.org/x86-64.txt>. * Makefile.am (KCONFIGS): New variable. (nobase_dist_guilemodule_DATA): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e5aa8bc20..41e0e67120 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,10 +102,14 @@ endif BUILD_DAEMON_OFFLOAD
guix/scripts/download.go: guix/build/download.go
guix/download.go: guix/build/download.go
+# Linux-Libre configurations.
+KCONFIGS = \
+ gnu/packages/linux-libre-i686.conf \
+ gnu/packages/linux-libre-x86_64.conf
GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go
-nobase_dist_guilemodule_DATA = $(MODULES)
+nobase_dist_guilemodule_DATA = $(MODULES) $(KCONFIGS)
nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm
# Do we need to provide our own non-broken (srfi srfi-37) module?