summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-26 14:07:31 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-27 00:49:23 +0200
commit12e5b26643e2269e8f30d8399886d4302c3c09d1 (patch)
treecd2b0cdb72957146a411c490bf430eb963118535 /Makefile.am
parentc2b8467645bb2c2e17eb9c580f39e345c4dc2f4a (diff)
build: Do not build (guix build syscalls) if 'mount' is missing from libc.
This disables compilation of this module on GNU/Hurd. Reported by Manolis Ragkousis <manolis837@gmail.com>. * m4/guix.m4 (GUIX_CHECK_LIBC_MOUNT): New variable. * configure.ac: Use it. Define 'BUILD_SYSCALLS_MODULE' conditional. * Makefile.am (MODULES, EXTRA_DIST): Make 'guix/build/syscalls.scm' conditional on BUILD_SYSCALLS_MODULE.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ada4cbea0b..76d505abf5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,7 +88,6 @@ MODULES = \
guix/build/rpath.scm \
guix/build/cvs.scm \
guix/build/svn.scm \
- guix/build/syscalls.scm \
guix/build/gremlin.scm \
guix/build/emacs-utils.scm \
guix/build/graft.scm \
@@ -124,6 +123,13 @@ MODULES = \
guix.scm \
$(GNU_SYSTEM_MODULES)
+if BUILD_SYSCALLS_MODULE
+
+MODULES += \
+ guix/build/syscalls.scm
+
+endif
+
if BUILD_DAEMON_OFFLOAD
MODULES += \
@@ -298,6 +304,13 @@ EXTRA_DIST += \
endif !BUILD_DAEMON_OFFLOAD
+if !BUILD_SYSCALLS_MODULE
+
+EXTRA_DIST += \
+ guix/build/syscalls.scm
+
+endif !BUILD_SYSCALLS_MODULE
+
CLEANFILES = \
$(GOBJECTS) \