summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-11 22:37:33 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-11 22:37:33 +0200
commit3a33730a86fb37c672f90418697eeb259318682d (patch)
treeeee98d31b5015792193bbe4f73e0b5fe230d7e3a /Makefile.am
parentf7ce90e7b94bc06aae8a28d493242969fbe7737c (diff)
build: Run `tests/guix-gc.sh' last to avoid test failures.
* Makefile.am (tests/guix-gc.log): New target. This should fix failures that occurred with "make check -j" the first time.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5370b104af..b55a780fe5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -340,6 +340,14 @@ AM_SCM_LOG_FLAGS = --no-auto-compile -L "$(top_srcdir)"
SH_LOG_COMPILER = $(top_builddir)/test-env $(SHELL)
AM_SH_LOG_FLAGS = -x -e
+# Make sure `tests/guix-gc.sh' runs last, after all the others. Otherwise it
+# could end up removing files from the store while they are being used by
+# other instances of the daemon.
+tests/guix-gc.log: \
+ $(patsubst %.sh,%.log,$(filter-out tests/guix-gc.sh,$(SH_TESTS))) \
+ $(SCM_TESTS:%.scm=%.log)
+
+
EXTRA_DIST = \
HACKING \
ROADMAP \