summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-24 23:41:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-29 14:09:22 -0400
commitebf5d77eab148394c6db0dd135ea119ca377aaed (patch)
treeac40f4699e358e9e24aa02125c37dae4dbe92880 /Makefile.am
parent54dc9d36fa4188b92f4dd8bc38897bf736b76e11 (diff)
build: Add the qcow2 file extension to the VM image.
Including the extension of the format type of the image is not only useful to the user, but also to software. One example is GNOME Boxes, which will reject an image with an unknown file extension. This should be fixed more definitely in Guix, where the output of the VM image derivation would already have the correct file extension but for now this will do. * Makefile.am (release): Add .qcow2 to the file extension of the VM images.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 834aedb97f..ab03dfab2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -901,9 +901,9 @@ release: dist-with-updated-version
echo "failed to produced Guix VM image for $$system" >&2 ; \
exit 1 ; \
fi ; \
- xz < "$$image" > "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.xz.tmp" ; \
- mv "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.xz.tmp" \
- "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.xz" ; \
+ xz < "$$image" > "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz.tmp" ; \
+ mv "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz.tmp" \
+ "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.qcow2.xz" ; \
done
@echo
@echo "Congratulations! All the release files are now in $(releasedir)."