summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-24 01:58:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-24 01:58:18 +0100
commit4d8f4a3f00268230f879a81f32524fd7c3576ad0 (patch)
tree59afedfc2fb422ef043e6624001290300ed6d800 /Makefile.am
parentc491f7f8de66d0f8386ba6fd7c2da5c3c0d1b24a (diff)
parentdc4851093ce6f3bd2ac71fa189ad87cd740cb656 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index eda87f3124..69e66fad75 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -410,6 +410,7 @@ SH_TESTS = \
tests/guix-gc.sh \
tests/guix-hash.sh \
tests/guix-pack.sh \
+ tests/guix-pack-localstatedir.sh \
tests/guix-pack-relocatable.sh \
tests/guix-package.sh \
tests/guix-package-net.sh \
@@ -600,13 +601,11 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-daemon \
ac_cv_guix_test_root="$(GUIX_TEST_ROOT)"
-# The self-contained tarball. Add 'glibc-utf8-locales' along with glibc just
-# so 'etc/profile' defines 'GUIX_LOCPATH' pointing to a valid set of locales.
+# The self-contained tarball.
guix-binary.%.tar.xz:
$(AM_V_GEN)GUIX_PACKAGE_PATH= \
tarball=`$(top_builddir)/pre-inst-env guix pack -K -C xz \
- -s "$*" --localstatedir guix glibc-utf8-locales \
- -e '(@@ (gnu packages commencement) glibc-final)'` ; \
+ -s "$*" --localstatedir --profile-name=current-guix guix` ; \
cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"