summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-26 18:27:04 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-26 21:21:05 +0200
commit82dc2b9af975ca79abf5e9c48f77ed4ffd7ccea5 (patch)
tree2149d52d897677e4a3ce662e719264d4ca07ac8a /Makefile.am
parentdc8907d8e322bce1b6c09c72711302cb3e733e1d (diff)
distro: Add an `ld' wrapper, to pass missing `-rpath' flags.
* distro/ld-wrapper.scm: New file. * Makefile.am (MODULES): Add it. * distro/base.scm (ld-wrapper-boot3): New variable. (%boot3-inputs): Add LD-WRAPPER-BOOT3. (bash-final, guile-final, ld-wrapper): New final. (%final-inputs): Use BASH-FINAL; add LD-WRAPPER. (gcc-4.7): Remove the `-rpath' trick from the `lib' spec string.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4845a48579..3de64a4edd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,8 @@ MODULES = \
guix/packages.scm \
guix.scm \
distro.scm \
- distro/base.scm
+ distro/base.scm \
+ distro/ld-wrapper.scm
GOBJECTS = $(MODULES:%.scm=%.go)