summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-19 21:50:57 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-19 21:50:57 +0200
commitac140f796633b36487d3bef0bb43ed9f10b62666 (patch)
treee7d7e33a4a6b872c30d6714ee492e379f15443ed /Makefile.am
parenta5b2570a1c10f1fbdcbbc173378ce0bdb090250d (diff)
build: Adjust 'gen-AUTHORS' for 'distcheck' and when run from a tarball.
* Makefile.am (gen-AUTHORS): Don't do anything if '.git' is missing. Remove "$(distdir)/AUTHORS" before invoking 'generate-authors.scm'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5cf9314014..870c6f914b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -389,9 +389,12 @@ gen-ChangeLog:
fi
gen-AUTHORS:
- $(top_builddir)/pre-inst-env "$(GUILE)" \
- "$(top_srcdir)/build-aux/generate-authors.scm" \
- "$(top_srcdir)" "$(distdir)/AUTHORS"
+ if test -d .git; then \
+ rm -f "$(distdir)/AUTHORS"; \
+ $(top_builddir)/pre-inst-env "$(GUILE)" \
+ "$(top_srcdir)/build-aux/generate-authors.scm" \
+ "$(top_srcdir)" "$(distdir)/AUTHORS"; \
+ fi
# Make sure we're not shipping a file that embeds a local /gnu/store file name.
assert-no-store-file-names: