summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-06-15 10:11:29 +0200
committerLudovic Courtès <ludo@gnu.org>2012-06-15 10:11:29 +0200
commit73d96596978b6a6f338e5444719a36bffd3fa521 (patch)
tree56f5caa886577c01a75bfdb53bab6d36aa8aeb4e /Makefile.am
parent48e8333d91ea64ccbc6e694393783498f1aa5d4b (diff)
build: Be cross-compilation-ready.
* Makefile.am (.scm.go): Pass `--target=$(host)'. * configure.ac: Use `AC_CANONICAL_HOST'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0a51552054..814bd3b355 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,6 +50,7 @@ CLEANFILES = $(GOBJECTS) *.log
GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH" \
$(GUILD) compile -L "$(top_srcdir)" \
-Wformat -Wunbound-variable -Warity-mismatch \
+ --target="$(host)" \
-o "$@" "$<"
SUFFIXES = .go