summaryrefslogtreecommitdiff
path: root/config-daemon.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-05-31 10:54:18 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-26 22:59:55 +0200
commitd11b96eb5493231a5a35045505ff8ae8aa746b8e (patch)
treec4e030ce5f75c6e73d4db000f23371501d2d0aed /config-daemon.ac
parent7c8d38f91e7bd4aed106aacc78eb454789538c31 (diff)
etc: Add explicit ‘--substitute-urls’ in guix-daemon service files.
Having substitute URLs explicitly listed in the service startup file makes it clearer what should be modified to permanently change the list of substitute URLs. * config-daemon.ac: Rename ‘guix_substitute_urls’ to ‘GUIX_SUBSTITUTE_URLS’ and substitute it. * nix/local.mk (etc/guix-%.service, etc/init.d/guix-daemon) (etc/guix-%.conf): Substitute it. * etc/guix-daemon.conf.in, etc/guix-daemon.service.in, etc/init.d/guix-daemon.in: Add an explicit ‘--substitute-urls’ option. Change-Id: Ie491b7fab5c42e54dca582801c03805a85de2bf9
Diffstat (limited to 'config-daemon.ac')
-rw-r--r--config-daemon.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/config-daemon.ac b/config-daemon.ac
index 9188f93bda..9854f1d694 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -106,12 +106,13 @@ if test "x$guix_build_daemon" = "xyes"; then
dnl Determine the appropriate default list of substitute URLs (GnuTLS
dnl is required so we can default to 'https'.)
- guix_substitute_urls="https://bordeaux.guix.gnu.org https://ci.guix.gnu.org"
+ GUIX_SUBSTITUTE_URLS="https://bordeaux.guix.gnu.org https://ci.guix.gnu.org"
AC_MSG_CHECKING([for default substitute URLs])
- AC_MSG_RESULT([$guix_substitute_urls])
+ AC_MSG_RESULT([$GUIX_SUBSTITUTE_URLS])
+ AC_SUBST([GUIX_SUBSTITUTE_URLS])
- AC_DEFINE_UNQUOTED([GUIX_SUBSTITUTE_URLS], ["$guix_substitute_urls"],
+ AC_DEFINE_UNQUOTED([GUIX_SUBSTITUTE_URLS], ["$GUIX_SUBSTITUTE_URLS"],
[Default list of substitute URLs used by 'guix-daemon'.])
dnl Check for Guile-SSH, which is required by 'guix offload'.