summaryrefslogtreecommitdiff
path: root/distro.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-06-30 16:37:19 +0200
committerLudovic Courtès <ludo@gnu.org>2012-06-30 16:37:19 +0200
commit6b1891b0a174f0fcbf26d4f404d3c2b4c63eb3e2 (patch)
tree25c62329c8b895c0abf1b703e566521e46bf55ac /distro.scm
parent39b9372ca7077afa938291f6cb3c88798e1cb704 (diff)
Add (distro) with a package searching facility.
* Makefile.am (MODULES): Add `distro.scm'. * distro.scm: New file. * po/POTFILES.in: Add it. * tests/packages.scm ("find-packages-by-name", "find-packages-by-name with version"): New tests.
Diffstat (limited to 'distro.scm')
-rw-r--r--distro.scm94
1 files changed, 94 insertions, 0 deletions
diff --git a/distro.scm b/distro.scm
new file mode 100644
index 0000000000..784e537deb
--- /dev/null
+++ b/distro.scm
@@ -0,0 +1,94 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro)
+ #:use-module (guix packages)
+ #:use-module (ice-9 ftw)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+ #:export (find-packages-by-name))
+
+;;; Commentary:
+;;;
+;;; General utilities for the software distribution---i.e., the modules under
+;;; (distro ...).
+;;;
+;;; Code:
+
+(define _ (cut gettext <> "guix"))
+
+(define %distro-module-directory
+ ;; Absolute path of the (distro ...) module root.
+ (string-append (dirname (search-path %load-path "distro.scm"))
+ "/distro"))
+
+(define (package-files)
+ "Return the list of files that implement distro modules."
+ (define prefix-len
+ (string-length (dirname %distro-module-directory)))
+
+ (file-system-fold (const #t) ; enter?
+ (lambda (path stat result) ; leaf
+ (if (string-suffix? ".scm" path)
+ (cons (substring path prefix-len) result)
+ result))
+ (lambda (path stat result) ; down
+ result)
+ (lambda (path stat result) ; up
+ result)
+ (const #f) ; skip
+ (lambda (path stat errno result)
+ (format (current-error-port)
+ (_ "warning: cannot access `~a': ~a")
+ path (strerror errno))
+ result)
+ '()
+ %distro-module-directory
+ stat))
+
+(define (package-modules)
+ "Return the list of modules that provide packages for the distribution."
+ (define not-slash
+ (char-set-complement (char-set #\/)))
+
+ (filter-map (lambda (path)
+ (let ((name (map string->symbol
+ (string-tokenize (string-drop-right path 4)
+ not-slash))))
+ (false-if-exception (resolve-interface name))))
+ (package-files)))
+
+(define* (find-packages-by-name name #:optional version)
+ "Return the list of packages with the given NAME. If VERSION is not #f,
+then only return packages whose version is equal to VERSION."
+ (define right-package?
+ (if version
+ (lambda (p)
+ (and (package? p)
+ (string=? (package-name p) name)
+ (string=? (package-version p) version)))
+ (lambda (p)
+ (and (package? p)
+ (string=? (package-name p) name)))))
+
+ (append-map (lambda (module)
+ (filter right-package?
+ (module-map (lambda (sym var)
+ (variable-ref var))
+ module)))
+ (package-modules)))