summaryrefslogtreecommitdiff
path: root/distro/packages/mit-krb5.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/mit-krb5.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/mit-krb5.scm')
-rw-r--r--distro/packages/mit-krb5.scm69
1 files changed, 0 insertions, 69 deletions
diff --git a/distro/packages/mit-krb5.scm b/distro/packages/mit-krb5.scm
deleted file mode 100644
index 13250ff95b..0000000000
--- a/distro/packages/mit-krb5.scm
+++ /dev/null
@@ -1,69 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages mit-krb5)
- #:use-module (distro)
- #:use-module (distro packages bison)
- #:use-module (distro packages perl)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public mit-krb5
- (package
- (name "mit-krb5")
- (version "1.11")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://web.mit.edu/kerberos/www/dist/krb5/"
- version
- "/krb5-" version
- "-signed.tar"))
- (sha256 (base32
- "0lc6lxb98qzg4x01lppq700vkr1ax9rld09znahrinwqnf9zndzy"))))
- (build-system gnu-build-system)
- (inputs `(("bison" ,bison)
- ("perl" ,perl)
- ))
- (arguments
- (lambda (system)
- `(#:tests? #f
- #:phases
- (alist-replace
- 'unpack
- (lambda* (#:key source #:allow-other-keys)
- (system* "echo" source)
- (let ((inner
- (substring source
- (string-index-right source #\k)
- (string-index-right source #\-))))
- (system* "echo" inner)
- (and (zero? (system* "tar" "xvf" source))
- (zero? (system* "tar" "xvf" (string-append inner ".tar.gz")))
- (chdir inner)
- (chdir "src"))))
- %standard-phases))))
- (synopsis "MIT Kerberos 5")
- (description
- "Massachusetts Institute of Technology implementation of Kerberos.
-Kerberos is a network authentication protocol designed to provide strong
-authentication for client/server applications by using secret-key cryptography.")
- (license (bsd-style "file://NOTICE"
- "See NOTICE in the distribution."))
- (home-page "http://web.mit.edu/kerberos/")))