summaryrefslogtreecommitdiff
path: root/distro/packages/patches/lsh-no-root-login.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-04 22:03:21 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-04 22:03:21 +0100
commit18d50d76216f5c207d8178cb2d2d2f31eb8fe3eb (patch)
treec6f0d54f57ea407c9e3e2a878d64099eba94148a /distro/packages/patches/lsh-no-root-login.patch
parent02b80c3f652bfd0814a37a0710822268f7934294 (diff)
distro: Add GNU lsh.
* distro/packages/lsh.scm, distro/packages/patches/lsh-guile-compat.patch: distro/packages/patches/lsh-no-root-login.patch: distro/packages/patches/lsh-pam-service-name.patch: New files. * Makefile.am (MODULES): Add lsh.scm. (dist_patch_DATA): Add the above patches.
Diffstat (limited to 'distro/packages/patches/lsh-no-root-login.patch')
-rw-r--r--distro/packages/patches/lsh-no-root-login.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/distro/packages/patches/lsh-no-root-login.patch b/distro/packages/patches/lsh-no-root-login.patch
new file mode 100644
index 0000000000..9dd81de3fb
--- /dev/null
+++ b/distro/packages/patches/lsh-no-root-login.patch
@@ -0,0 +1,16 @@
+Correctly handle the `--no-root-login' option.
+
+--- lsh-2.0.4/src/lshd.c 2006-05-01 13:47:44.000000000 +0200
++++ lsh-2.0.4/src/lshd.c 2009-09-08 12:20:36.000000000 +0200
+@@ -758,6 +758,10 @@ main_argp_parser(int key, char *arg, str
+ self->allow_root = 1;
+ break;
+
++ case OPT_NO_ROOT_LOGIN:
++ self->allow_root = 0;
++ break;
++
+ case OPT_KERBEROS_PASSWD:
+ self->pw_helper = PATH_KERBEROS_HELPER;
+ break;
+