summaryrefslogtreecommitdiff
path: root/distro/packages/rsync.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/rsync.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/rsync.scm')
-rw-r--r--distro/packages/rsync.scm51
1 files changed, 0 insertions, 51 deletions
diff --git a/distro/packages/rsync.scm b/distro/packages/rsync.scm
deleted file mode 100644
index 8dc0acb118..0000000000
--- a/distro/packages/rsync.scm
+++ /dev/null
@@ -1,51 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages rsync)
- #:use-module (distro)
- #:use-module (distro packages perl)
- #:use-module (distro packages acl)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-
-(define-public rsync
- (package
- (name "rsync")
- (version "3.0.9")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://rsync.samba.org/ftp/rsync/rsync-"
- version ".tar.gz"))
- (sha256
- (base32
- "01bw4klqsrlhh3i9lazd485sd9qx5djvnwa21lj2h3a9sn6hzw9h"))))
- (build-system gnu-build-system)
- (inputs `(("perl" ,perl)
- ("acl" ,acl)))
- (synopsis "rsync, a remote (and local) file copying tool")
- (description
- "rsync is a fast and versatile file copying tool. It can copy locally,
-to/from another host over any remote shell, or to/from a remote rsync daemon.
-Its delta-transfer algorithm reduces the amount of data sent over the network
-by sending only the differences between the source files and the existing
-files in the destination.")
- (license gpl3+)
- (home-page "http://rsync.samba.org/")))