summaryrefslogtreecommitdiff
path: root/distro/packages/typesetting.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:02 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:26 +0100
commite76bdf8b87920b87a2a2e728c2e40ff24ca39ffe (patch)
treeffcb4e08f2d00acaf670c8344e6a12da6ea39772 /distro/packages/typesetting.scm
parent81dbd783bd9afabd1d8720c9b60a6a93492bb581 (diff)
build: Clearly mark Nixpkgs as optional.
* configure.ac: Always show the result of checking for Nixpkgs. Don't warn when Nixpkgs is not found. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Remove `--with-nixpkgs' flag. * guix/utils.scm (%nixpkgs-directory): Use either the compile-time or the run-time `NIXPKGS' environment variable. * release.nix (jobs.tarball, jobs.build): Remove `--with-nixpkgs' configure flag. * README: Mark Nixpkgs as optional. * distro/packages/databases.scm, distro/packages/guile.scm, distro/packages/typesetting.scm: Change uses of `nixpkgs-derivation*' to `nixpkgs-derivation', to avoid failing at compile-time.
Diffstat (limited to 'distro/packages/typesetting.scm')
-rw-r--r--distro/packages/typesetting.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/distro/packages/typesetting.scm b/distro/packages/typesetting.scm
index 5ca33c628a..40c9e998a0 100644
--- a/distro/packages/typesetting.scm
+++ b/distro/packages/typesetting.scm
@@ -94,7 +94,7 @@
"12gkyqrn0kaa8xq7sc7v3wm407pz2fxg9ngc75aybhi5z825b9vq"))))
(build-system gnu-build-system) ; actually, just a makefile
(outputs '("out" "doc"))
- (inputs `(("ghostscript" ,(nixpkgs-derivation* "ghostscript"))))
+ (inputs `(("ghostscript" ,(nixpkgs-derivation "ghostscript"))))
(arguments `(#:modules ((guix build utils)
(guix build gnu-build-system)
(srfi srfi-1)) ; we need SRFI-1