summaryrefslogtreecommitdiff
path: root/distro/packages/wget.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/wget.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/wget.scm')
-rw-r--r--distro/packages/wget.scm61
1 files changed, 0 insertions, 61 deletions
diff --git a/distro/packages/wget.scm b/distro/packages/wget.scm
deleted file mode 100644
index 08b16f167b..0000000000
--- a/distro/packages/wget.scm
+++ /dev/null
@@ -1,61 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages wget)
- #:use-module (guix licenses)
- #:use-module ((distro packages gettext)
- #:renamer (symbol-prefix-proc 'guix:))
- #:use-module (distro packages gnutls)
- #:use-module (distro packages perl)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public wget
- (package
- (name "wget")
- (version "1.14")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/wget/wget-"
- version ".tar.xz"))
- (sha256
- (base32
- "0yqllj3nv9p3vqbdm6j4nvpjcwf1y19rq8sd966nrbd2qvvxfq8p"))))
- (build-system gnu-build-system)
- (inputs
- `(("gnutls" ,gnutls)
- ("perl" ,perl)
- ("gettext" ,guix:gettext)))
- (arguments
- '(#:phases
- (alist-cons-before 'build 'patch-/usr/bin/env
- (lambda _
- (for-each patch-shebang
- '("doc/texi2pod.pl" "tests/run-px")))
- %standard-phases)))
- (home-page "http://www.gnu.org/software/wget/")
- (synopsis
- "GNU Wget, a tool for retrieving files using HTTP, HTTPS, and FTP")
- (description
- "GNU Wget is a free software package for retrieving files using HTTP,
-HTTPS and FTP, the most widely-used Internet protocols. It is a
-non-interactive commandline tool, so it may easily be called from
-scripts, cron jobs, terminals without X-Windows support, etc.")
- (license gpl3+))) ; some files are under GPLv2+