summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorMiguel Ángel Arruga Vivas <rosen644835@gmail.com>2020-10-24 14:35:09 +0200
committerMiguel Ángel Arruga Vivas <rosen644835@gmail.com>2020-10-24 17:38:58 +0200
commitef6596a20cac24dbfd729098f2a903f00f4e33e2 (patch)
tree83b7fdfedb6131e853bfc643b86fe5ee0d534ab3 /doc
parent31c894c652aac27bd0ed8594a4344fd7c2b31e6e (diff)
build: Add GUIX_GIT_KEYRING variable for make authenticate.
* Makefile.am (GUIX_GIT_KEYRING): New variable. (authenticate): Use GUIX_GIT_KEYRING to select the keyring branch reference. * doc/contributing.texi (Building from Git): Add an example about the use of GUIX_GIT_KEYRING.
Diffstat (limited to 'doc')
-rw-r--r--doc/contributing.texi10
1 files changed, 10 insertions, 0 deletions
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 26a4627464..d3f6325c3f 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -140,6 +140,16 @@ make authenticate
The first run takes a couple of minutes, but subsequent runs are faster.
+Or, when your configuration for your local Git repository doesn't match
+the default one, you can provide the reference for the @code{keyring}
+branch through the variable @code{GUIX_GIT_KEYRING}. The following
+example assumes that you have a Git remote called @samp{myremote}
+pointing to the official repository:
+
+@example
+make authenticate GUIX_GIT_KEYRING=myremote/keyring
+@end example
+
@quotation Note
You are advised to run @command{make authenticate} after every
@command{git pull} invocation. This ensures you keep receiving valid