summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-23 14:56:38 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-27 21:41:15 +0200
commit8819551c8d2a12cd4e84e09b51e434d05a012c9d (patch)
tree5eedd6a9dfc7f2f37fc330c2571592045aaada0c /doc
parentb3fc03ee266a5f6d810d780582d458e561efccf3 (diff)
packages: 'package-input-rewriting' has a #:deep? parameter.
* guix/packages.scm (package-input-rewriting): Add #:deep? and pass it to 'package-mapping'. [replacement-property]: New variable. [rewrite]: Check it. [cut?]: New procedure. * tests/packages.scm ("package-input-rewriting"): Pass #:deep? #f and ensure implicit inputs were not rewritten. Avoid 'eq?' comparisons. ("package-input-rewriting, deep"): New test. * gnu/packages/guile.scm (package-for-guile-2.0, package-for-guile-3.0): Pass #:deep? #f.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi10
1 files changed, 5 insertions, 5 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index e72e1ec130..0805e2d508 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -6238,12 +6238,12 @@ transformation is @dfn{input rewriting}, whereby the dependency tree of
a package is rewritten by replacing specific inputs by others:
@deffn {Scheme Procedure} package-input-rewriting @var{replacements} @
- [@var{rewrite-name}]
+ [@var{rewrite-name}] [#:deep? #t]
Return a procedure that, when passed a package, replaces its direct and
-indirect dependencies (but not its implicit inputs) according to
-@var{replacements}. @var{replacements} is a list of package pairs; the
-first element of each pair is the package to replace, and the second one
-is the replacement.
+indirect dependencies, including implicit inputs when @var{deep?} is
+true, according to @var{replacements}. @var{replacements} is a list of
+package pairs; the first element of each pair is the package to replace,
+and the second one is the replacement.
Optionally, @var{rewrite-name} is a one-argument procedure that takes
the name of a package and returns its new name after rewrite.