summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-17 21:58:04 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-18 00:25:49 +0200
commit39bee8a2937ea28e74b5c807962fb8bc87fe6887 (patch)
treeb4141bbc425ef3d788d1cf4827ccb4dbe86f1620 /doc
parent84189ebc66266f03b9ca7e8b912d529886436851 (diff)
Add 'guix edit'.
* guix/scripts/edit.scm: New file. * Makefile.am (MODULES): Add it. * doc.am (SUBCOMMANDS): Add 'edit'. * doc/guix.texi (Defining Packages): Add xref to "Invoking guix edit". (Invoking guix edit): New node. * po/guix/POTFILES.in: Add it.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi29
1 files changed, 28 insertions, 1 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 1c7f4e1232..a93003d625 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -124,6 +124,7 @@ Defining Packages
Utilities
* Invoking guix build:: Building packages from the command line.
+* Invoking guix edit::
* Invoking guix download:: Downloading a file and printing its hash.
* Invoking guix hash:: Computing the cryptographic hash of a file.
* Invoking guix import:: Importing package definitions.
@@ -1931,7 +1932,10 @@ unavailable to the build process, possibly leading to a build failure.
Once a package definition is in place, the
package may actually be built using the @code{guix build} command-line
-tool (@pxref{Invoking guix build}). @xref{Packaging Guidelines}, for
+tool (@pxref{Invoking guix build}). You can easily jump back to the
+package definition using the @command{guix edit} command
+(@pxref{Invoking guix edit}).
+@xref{Packaging Guidelines}, for
more information on how to test package definitions, and
@ref{Invoking guix lint}, for information on how to check a definition
for style conformance.
@@ -3261,6 +3265,7 @@ programming interface of Guix in a convenient way.
@menu
* Invoking guix build:: Building packages from the command line.
+* Invoking guix edit:: Editing package definitions.
* Invoking guix download:: Downloading a file and printing its hash.
* Invoking guix hash:: Computing the cryptographic hash of a file.
* Invoking guix import:: Importing package definitions.
@@ -3548,6 +3553,28 @@ the parsed command-line options.
@end defvr
+@node Invoking guix edit
+@section Invoking @command{guix edit}
+
+@cindex package definition, editing
+So many packages, so many source files! The @command{guix edit} command
+facilitates the life of packagers by pointing their editor at the source
+file containing the definition of the specified packages. For instance:
+
+@example
+guix edit gcc-4.8 vim
+@end example
+
+@noindent
+launches the program specified in the @code{EDITOR} environment variable
+to edit the recipe of GCC@tie{}4.8.4 and that of Vim.
+
+If you are using Emacs, note that the Emacs user interface provides
+similar functionality in the ``package info'' buffers created by
+@kbd{M-x guix-search-by-name} and similar commands (@pxref{Emacs
+Commands}).
+
+
@node Invoking guix download
@section Invoking @command{guix download}