summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 10:36:45 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 17:37:40 +0100
commitaaf75c890b5242d3ab3671766226bc53ab07049a (patch)
treeba4cccb93365a7d603c15ee8b60f860af05be4cd /doc
parent043a51c0c2a025b84b0fb14c157add7236d7a526 (diff)
gnu: ensure pip and setuptools are installed even for Python 2.
* gnu/packages/python.scm (python-2.7): Add "--with-ensurepip=install" to configure-flags. * doc/guix.texi (Python Modules): Document it.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi9
1 files changed, 6 insertions, 3 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index a3eba5811e..2691e24faf 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -13579,7 +13579,6 @@ for instance, the module python-dateutil is packaged under the names
starts with @code{py} (e.g. @code{pytz}), we keep it and prefix it as
described above.
-
@subsubsection Specifying Dependencies
@cindex inputs, for Python packages
@@ -13596,6 +13595,11 @@ following check list to determine which dependency goes where.
@itemize
@item
+We currently package Python 2 with @code{setuptools} and @code{pip}
+installed like Python 3.4 has per default. Thus you don't need to
+specify either of these as an input.
+
+@item
Python dependencies required at run time go into
@code{propagated-inputs}. They are typically defined with the
@code{install_requires} keyword in @file{setup.py}, or in the
@@ -13609,8 +13613,7 @@ testing---e.g., those in @code{tests_require}---go into
propagated because they are not needed at run time, and (2) in a
cross-compilation context, it's the ``native'' input that we'd want.
-Examples are @code{setuptools}, which is usually needed only at build
-time, or the @code{pytest}, @code{mock}, and @code{nose} test
+Examples are the @code{pytest}, @code{mock}, and @code{nose} test
frameworks. Of course if any of these packages is also required at
run-time, it needs to go to @code{propagated-inputs}.