summaryrefslogtreecommitdiff
path: root/gnu/installer/newt/keymap.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-04-08 10:16:25 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-08 10:24:02 +0200
commit07a53bd512530d8f87e076263227216c467727bb (patch)
treee148fdd21429cea95a39861d536d0cec37984b54 /gnu/installer/newt/keymap.scm
parent6e2f7dc5e23f07855da808cf2e4f825680b23d50 (diff)
installer: Turn help menu into parameters menu.
* gnu/local.mk (INSTALLER_MODULES): Rename help.scm into parameters.scm. * po/guix/POTFILES.in: Ditto. * gnu/installer/record.scm (<installer>): Rename help-menu into parameter-menu and help-page into parameters-page. * gnu/installer/newt/parameters.scm: Renamed from help.scm. Update information messages. * gnu/installer/newt.scm: Update accordingly. * gnu/installer/newt/keymap.scm: Ditto.
Diffstat (limited to 'gnu/installer/newt/keymap.scm')
-rw-r--r--gnu/installer/newt/keymap.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/installer/newt/keymap.scm b/gnu/installer/newt/keymap.scm
index 0147a0b9d5..8625afaa03 100644
--- a/gnu/installer/newt/keymap.scm
+++ b/gnu/installer/newt/keymap.scm
@@ -39,21 +39,21 @@
#:title title
#:info-text
(case context
- ((help) (G_ "Please choose your keyboard layout. \
+ ((param) (G_ "Please choose your keyboard layout. \
It will only be used during the installation process."))
(else (G_ "Please choose your keyboard layout. \
It will be used during the install process, and for the installed system. \
-You can switch to different layout at any time from the help menu.")))
+You can switch to different layout at any time from the parameters menu.")))
#:listbox-items layouts
#:listbox-item->text layout->text
#:sort-listbox-items? #f
#:button-text
(case context
- ((help) (G_ "Continue"))
+ ((param) (G_ "Continue"))
(else (G_ "Exit")))
#:button-callback-procedure
(case context
- ((help) (const #t))
+ ((param) (const #t))
(else
(lambda _
(raise