summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-20 13:57:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-20 13:57:22 +0300
commit00537ec17ddccfb41c0d9b27bf1bc4c47a8bd54e (patch)
treec83b83747df2a235bb0f3c10992f785660484bd4 /gnu/packages/admin.scm
parent5a9e3b7c3981f684f601e2d21e8202223b384de9 (diff)
gnu: tree: Update to 2.0.4.
* gnu/packages/admin.scm (tree): Update to 2.0.4. [arguments]: Add phase to fix the version string in the man page.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5fb621e027..be5f11e42b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2506,20 +2506,24 @@ characters can be replaced as well, as can UTF-8 characters.")
(define-public tree
(package
(name "tree")
- (version "2.0.3")
+ (version "2.0.4")
(source (origin
(method url-fetch)
(uri (string-append
"http://mama.indstate.edu/users/ice/tree/src/tree-"
version ".tgz"))
(sha256
- (base32 "079vda37d5i3nfx12wx81z6r6bxynv2jww1z1hjziiwxbxxyf55s"))))
+ (base32 "0x7s9wxvf83fw4qah16kapswl2277pybw3d514zrlms9g0cr5smh"))))
(build-system gnu-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- (delete 'configure)) ; No configure script.
+ (delete 'configure) ; No configure script.
+ (add-after 'unpack 'fix-manpage-version
+ (lambda _
+ (substitute* "doc/tree.1"
+ (("Tree 2\\.0\\.0") (string-append "Tree " #$version))))))
#:tests? #f ; No check target.
#:make-flags
#~(list (string-append "PREFIX=" #$output)