summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-07-05 17:34:04 +0100
committerLudovic Courtès <ludo@gnu.org>2023-07-18 00:41:15 +0200
commit460b2afeb39733ee8d2730b35192c97630fc2a10 (patch)
treeeb29de7a5f0b0103c7bed6db65c8c1ad682fd1e6 /gnu/packages/admin.scm
parent602e32c8e0e36d149e1424d8023a214abd3d34ba (diff)
gnu: Add mactelnet.
* gnu/packages/admin.scm (mactelnet): New variable. * gnu/packages/patches/mactelnet-remove-init.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index dfd6bf0e41..f2378b0d8a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5852,3 +5853,44 @@ file or files to several hosts.")
(description "This package provides a graphical disk usage analyzer in
text mode.")
(license license:asl2.0)))
+
+(define-public mactelnet
+ (package
+ (name "mactelnet")
+ (version "0.4.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/haakonnessjoen/MAC-Telnet")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z63dz22crrvrm0sh2cwpyqb7wqd9m45m6f2641mwmyp6hcpf4k4"))
+ (patches (search-patches "mactelnet-remove-init.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ; no tests
+ (native-inputs (list autoconf automake gettext-minimal))
+ (synopsis "MAC-Telnet utilities for communicating with RouterOS devices")
+ (description "This package provides an implementation of the MAC-Telnet protocol
+used by RouterOS devices. It provides the following commands:
+@table @command
+@item{macping}
+Ping RouterOS devices or @command{mactelnetd} hosts.
+@item{mactelnetd}
+MAC-Telnet daemon.
+@item{mactelnet}
+MAC-Telnet client.
+@item{mndp}
+Discover other RouterOS devices or @command{mactelnetd} hosts.
+@end table")
+ (home-page "https://lunatic.no/2010/10/routeros-mac-telnet-application-for-linux-users/")
+ (license
+ (list license:gpl2+
+ ;; Note: applies to src/md5.{c,h}
+ ;; This file is likely to be gone in the next release.
+ license:zlib
+ ;; Bundled uthash-1.9.9.
+ license:bsd-2))))