summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTomás Ortín <tomasortin@mailbox.org>2023-11-22 11:04:42 +0100
committerLudovic Courtès <ludo@gnu.org>2024-02-20 10:57:17 +0100
commitffcce77ec488e3c89401ad77fafa65fcd9e9f5be (patch)
tree6f10736ded8d293d0c89305f2e3314a1ab2a8a3e /gnu/packages/admin.scm
parenta2eaa97637e9f35996ee022624cec3b76cb21c3d (diff)
gnu: Add rdfind.
* gnu/packages/admin.scm (rdfind): New variable. Change-Id: Ie25bb6b8f5f9a3942eec8d9346da99d73e3bf1dd Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 47c82e9678..601c3b8fac 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2023 Tobias Kortkamp <tobias.kortkamp@gmail.com>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -152,6 +153,7 @@
#:use-module (gnu packages mcrypt)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages nettle)
#:use-module (gnu packages networking)
#:use-module (gnu packages openldap)
#:use-module (gnu packages package-management)
@@ -6119,3 +6121,34 @@ breadth-first rather than depth-first. It is otherwise compatible with many
versions of @command{find}, including POSIX, GNU, and *BSD find.")
(home-page "https://tavianator.com/projects/bfs.html")
(license license:bsd-0)))
+
+(define-public rdfind
+ (package
+ (name "rdfind")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://rdfind.pauldreik.se/" name "-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "0y9j1w3nbgjks0k4kgm6qq92yrwgv66n212ncmlmhsl8y676wh3s"))))
+ (build-system gnu-build-system)
+ (native-inputs (list which))
+ (inputs (list nettle))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'patch-tests
+ (lambda _
+ (display (which "echo"))
+ (substitute* "testcases/common_funcs.sh"
+ (("/bin/echo")
+ (which "echo"))))))))
+ (home-page "https://rdfind.pauldreik.se")
+ (synopsis "Find duplicate files")
+ (description
+ "Rdfind is a command line tool that finds duplicate files based on
+their content instead of their file names. It is useful for compressing
+backup directories or just finding duplicate files.")
+ (license license:gpl2+)))