summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex.sassmannshausen@gmail.com>2015-03-04 20:34:44 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-06 00:44:01 +0100
commit15926aec0d5b72961599ace50082baee5c01ae7e (patch)
treefff2ffc3b9e3a8c8961f6e72f42d6aa83600a547 /gnu/packages/admin.scm
parent43640a33f4bbfa8e1c5ece792d39f7f548867c13 (diff)
gnu: Add tree.
* gnu/packages/admin.scm (tree): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 72d8022f9a..c85204f3ae 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
+;;; Copyright © 2015 Alex Sassmannshausen <alex.sassmannshausen@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -968,6 +969,31 @@ characters can be replaced as well, as can UTF-8 characters.")
recover lost partitions and/or make non-booting disks bootable again.")
(license license:gpl2+)))
+(define-public tree
+ (package
+ (name "tree")
+ (version "1.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://mama.indstate.edu/users/ice/tree/src/tree-"
+ version ".tgz"))
+ (sha256
+ (base32 "04kviw799qxly08zb8n5mgxfd96gyis6x69q2qiw86jnh87c4mv9"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-delete 'configure %standard-phases)
+ #:tests? #f ; no check target
+ #:make-flags (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "prefix=" out)))))
+ (synopsis "Recursively list the contents of a directory")
+ (description
+ "Tree is a recursive directory listing command that produces a depth
+indented listing of files, which is colorized ala dircolors if the LS_COLORS
+environment variable is set and output is to tty.")
+ (home-page "http://mama.indstate.edu/users/ice/tree/")
+ (license license:gpl2+)))
+
(define-public direvent
(package
(name "direvent")