summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-02-11 13:18:42 -0500
committerLeo Famulari <leo@famulari.name>2017-02-11 13:43:42 -0500
commit52701a3d35b471daf504bd313403d3fd2c88fb2d (patch)
treec2628634ccbf899169551d8397fda23feb9330de /gnu/packages/admin.scm
parentc6b6a74e77579b198f57b6bf98925e72e60a0481 (diff)
gnu: shadow: Use 'modify-phases'.
* gnu/packages/admin.scm (shadow): Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5dc1fff9a5..ea8b4837b5 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
-;;; Coypright © 2016, 2017 ng0 <ng0@we.make.ritual.n0.is>
+;;; Coypright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Coypright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Coypright © 2016 John Darrington <jmd@gnu.org>
;;;
@@ -283,27 +283,27 @@ client and server, a telnet client and server, and an rsh client and server.")
(arguments
'(;; Assume System V `setpgrp (void)', which is the default on GNU
;; variants (`AC_FUNC_SETPGRP' is not cross-compilation capable.)
- #:configure-flags '("--with-libpam" "ac_cv_func_setpgrp_void=yes")
+ #:configure-flags
+ '("--with-libpam" "ac_cv_func_setpgrp_void=yes")
- #:phases (alist-cons-before
- 'build 'set-nscd-file-name
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Use the right file name for nscd.
- (let ((libc (assoc-ref inputs "libc")))
- (substitute* "lib/nscd.c"
- (("/usr/sbin/nscd")
- (string-append libc "/sbin/nscd")))))
- (alist-cons-after
- 'install 'remove-groups
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Remove `groups', which is already provided by Coreutils.
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (man (string-append out "/share/man")))
- (delete-file (string-append bin "/groups"))
- (for-each delete-file (find-files man "^groups\\."))
- #t))
- %standard-phases))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-nscd-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Use the right file name for nscd.
+ (let ((libc (assoc-ref inputs "libc")))
+ (substitute* "lib/nscd.c"
+ (("/usr/sbin/nscd")
+ (string-append libc "/sbin/nscd"))))))
+ (add-after 'install 'remove-groups
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Remove `groups', which is already provided by Coreutils.
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man (string-append out "/share/man")))
+ (delete-file (string-append bin "/groups"))
+ (for-each delete-file (find-files man "^groups\\."))
+ #t))))))
(inputs (if (string-suffix? "-linux"
(or (%current-target-system)