summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-06-20 23:54:20 -0500
committerEric Bavier <bavier@member.fsf.org>2016-06-20 23:54:20 -0500
commit0405e5f49133171602ea9749f5d9fb6bcdcf2669 (patch)
tree2b6e25b746e9e6c532dc3076ba8dffa3ef9420ea /gnu/packages/admin.scm
parent7108425c37a3232f6d28964c626d87235300b8d1 (diff)
gnu: Add thefuck.
* gnu/packages/admin.scm (thefuck): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 78f36a18cf..415a35aab3 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1681,3 +1681,30 @@ controller, or compare the network bandwidth numbers directly with the disk
throughput (in the same interval).")
(home-page "http://dag.wiee.rs/home-made/dstat/")
(license license:gpl2+)))
+
+(define-public thefuck
+ (package
+ (name "thefuck")
+ (version "3.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nvbn/thefuck/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g4s2vkpl0mqhkdkbzib07qr4xf0cq25fvhdhna52290qgd69pwf"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-decorator" ,python-decorator)
+ ("python-psutil" ,python-psutil)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/nvbn/thefuck")
+ (synopsis "Correct mistyped console command")
+ (description
+ "The Fuck tries to match a rule for a previous, mistyped command, creates
+a new command using the matched rule, and runs it.")
+ (license license:x11)))