summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-09 16:47:37 +0000
committerRicardo Wurmus <rekado@elephly.net>2016-08-10 22:39:14 +0200
commit5ec8b02d1039b511e53b80fadaed9f062c01f9c3 (patch)
tree90e74421d5d8723a0be6a082352eac9eb9f986e4 /gnu/packages/admin.scm
parentdd05e73102e19299ebc1d0daf8d95016075e048d (diff)
gnu: Add cbatticon.
* gnu/packages/admin.scm (cbatticon): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index eada7962d2..09a883c89c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
+;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -70,7 +71,9 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages python)
#:use-module (gnu packages man)
- #:use-module (gnu packages autotools))
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk))
(define-public aide
(package
@@ -1698,3 +1701,36 @@ a new command using the matched rule, and runs it.")
display your disk usage in whatever format you prefer. It is designed to be
highly portable. Great for heterogenous networks.")
(license license:zlib)))
+
+(define-public cbatticon
+ (package
+ (name "cbatticon")
+ (version "1.6.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/valr/"
+ name "/archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "023fvsa4q7rl98rqgwrb1shyzaybdkkbyz5sywd0s5p7ixkksxqx"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("gnu-gettext" ,gnu-gettext)
+ ("libnotify" ,libnotify)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Lightweight battery icon for the system tray")
+ (description "cbatticon is a lightweight battery icon that displays
+the status of your battery in the system tray.")
+ (home-page "https://github.com/valr/cbatticon")
+ (license license:gpl2+)))