summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-10 11:13:36 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:26 +0100
commit48160559a1a443f8d3024376ab79a925b25ebc42 (patch)
tree07faf41bf6564bae5afb9ab098626380dffae8cb /gnu/packages/admin.scm
parenta08a8350343145b18301ba0926787c0e28ee24fc (diff)
gnu: thefuck: Fix build.
Requires setuptools >= 17.1 due to some features used, while our python currently only includes 12.0. * gnu/packages/admin.scm (thefuck): Add setuptools to native-inputs.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ee07b3be8a..f1c283c7c2 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1701,6 +1701,10 @@ throughput (in the same interval).")
("python-decorator" ,python-decorator)
("python-psutil" ,python-psutil)
("python-six" ,python-six)))
+ (inputs
+ ;; Requires setuptools >= 17.1 due to some features used, while our
+ ;; python currently only includes 12.0. TODO: Remove this input.
+ `(("python-setuptools" ,python-setuptools)))
(home-page "https://github.com/nvbn/thefuck")
(synopsis "Correct mistyped console command")
(description