summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorJohn J. Foerch <jjfoerch@earthlink.net>2016-07-02 15:08:30 -0400
committerLeo Famulari <leo@famulari.name>2016-07-07 20:38:49 -0400
commit614023981a355421256f6281ae897e9e738706e6 (patch)
treec28077edecb4715729c1cd7f9a03236b928d5cca /gnu/packages/admin.scm
parent1a5fd02a829132d3cf3a95db5521c83d0a16d3c1 (diff)
gnu: Add di.
* gnu/packages/admin.scm (di): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 447a96d4e8..1d08be9e13 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
+;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1705,3 +1706,34 @@ throughput (in the same interval).")
"The Fuck tries to match a rule for a previous, mistyped command, creates
a new command using the matched rule, and runs it.")
(license license:x11)))
+
+(define-public di
+ (package
+ (name "di")
+ (version "4.42")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gentoo.com/di/di-" version ".tar.gz"))
+ (sha256
+ (base32 "1i6m9zdnidn8268q1lz9fd8payk7s4pgwh5zlam9rr4dy6h6a67n"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; Obscure test failures.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'setup-environment
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "CC" "gcc")
+ (setenv "prefix" (assoc-ref outputs "out"))
+ #t)))
+ #:make-flags (list "--environment-overrides")))
+ (home-page "https://www.gentoo.com/di/")
+ (synopsis "Advanced df like disk information utility")
+ (description
+ "'di' is a disk information utility, displaying everything
+(and more) that your @code{df} command does. It features the ability to
+display your disk usage in whatever format you prefer. It is designed to be
+highly portable. Great for heterogenous networks.")
+ (license license:zlib)))