summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-05-01 13:38:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-01 13:38:58 +0200
commit2e402618f653f0801358cad74e3030972c975387 (patch)
treedeab069f712e870ebe95541c381c2b9d5379c295 /gnu/packages/admin.scm
parentd13f45646ba2c2944b4c787e40fc73a59089dd9d (diff)
gnu: shadow: Update to 4.6.
* gnu/packages/admin.scm (shadow): Update to 4.6. [source]: Remove upstreamed patch. * gnu/packages/patches/shadow-CVE-2018-7169.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a9723817b1..4a2fe145f5 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -358,16 +358,15 @@ hostname.")
(define-public shadow
(package
(name "shadow")
- (version "4.5")
+ (version "4.6")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/shadow-maint/shadow/releases/"
"download/" version "/shadow-" version ".tar.xz"))
- (patches (search-patches "shadow-CVE-2018-7169.patch"))
(sha256
(base32
- "0hdpai78n63l3v3fgr3kkiqzhd0awrpfnnzz4mf7lmxdh61qb37w"))))
+ "10smy01km2bqjjvsd2jz17zvrxbzj89qczyb1amk38j28bcci609"))))
(build-system gnu-build-system)
(arguments
`(;; Assume System V `setpgrp (void)', which is the default on GNU