summaryrefslogtreecommitdiff
path: root/gnu/packages/agda.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-04-30 12:10:06 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-06-04 10:59:35 +0200
commit8203e8f3c9cf0462abb9f03e42e578fe28599c36 (patch)
treefbb74cb82a4df6f3fec7fec826da81d4426e7e65 /gnu/packages/agda.scm
parentc1f8bcbbda4d90dc98d5e808049f008dffe6b979 (diff)
gnu: Add agda-categories.
* gnu/packages/patches/agda-categories-use-find.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/agda.scm: New variable agda-categories.
Diffstat (limited to 'gnu/packages/agda.scm')
-rw-r--r--gnu/packages/agda.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index dd427bff02..16573e6d57 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -232,3 +232,33 @@ try agda-prelude instead.")
(home-page "https://wiki.portal.chalmers.se/agda/pmwiki.php")
(license license:expat)))
+(define-public agda-categories
+ (package
+ (name "agda-categories")
+ (version "0.1.7.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/agda/agda-categories.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xwgm2mfl2pxipsv31bin8p14y1yhd9n27lv3clvsxd4z9yc034m"))
+ (patches (search-patches "agda-categories-remove-incompatible-flags.patch"
+ "agda-categories-use-find.patch"))))
+ (build-system agda-build-system)
+ (arguments
+ (list
+ #:gnu-and-haskell? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (invoke "make"))))))
+ (propagated-inputs
+ (list agda-stdlib))
+ (synopsis "New Categories library for Agda")
+ (description "A new Categories library for Agda")
+ (home-page "https://github.com/agda/agda-categories")
+ (license license:expat)))