summaryrefslogtreecommitdiff
path: root/gnu/packages/agda.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-01 16:33:52 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2023-06-04 10:59:30 +0200
commitaf5d228b1303989812e48093769715fd19df5042 (patch)
treec099b25bc5188c8b5b50dbf04f70401447b2faa0 /gnu/packages/agda.scm
parentcc67085077c06b560840d24b3d00624313904206 (diff)
gnu: agda: Update to 2.6.3 and switch to git-fetch.
* gnu/packages/agda.scm (agda): Update to 2.6.3, switch to fetching using git so that doc files are included, and add new dependency ghc-vector-hashtables.
Diffstat (limited to 'gnu/packages/agda.scm')
-rw-r--r--gnu/packages/agda.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 7128a3f108..fc1085ec09 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,15 +38,17 @@
(define-public agda
(package
(name "agda")
- (version "2.6.2.2")
+ (version "2.6.3")
(source
(origin
- (method url-fetch)
- (uri (hackage-uri "Agda" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/agda/agda.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0yjjbhc593ylrm4mq4j01nkdvh7xqsg5in30wxj4y53vf5hkggp5"))))
+ (base32 "1s7zd01i8pmvi90ywx497kc07z50nah7h0fc2dn6jzb132k5sh1q"))))
(build-system haskell-build-system)
- (properties '((upstream-name . "Agda")))
(inputs
(list ghc-aeson
ghc-alex
@@ -68,6 +71,7 @@
ghc-strict
ghc-unordered-containers
ghc-uri-encode
+ ghc-vector-hashtables
ghc-zlib))
(arguments
(list #:modules `((guix build haskell-build-system)