summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-09-02 21:55:18 -0700
committerRicardo Wurmus <rekado@elephly.net>2023-09-08 10:53:37 +0200
commit3eb77954f969df41c000e7018a6b598b9f562d8d (patch)
tree96f26c991ccaf9156c881e5fcce81a862cd6641b /gnu/packages/algebra.scm
parent2d366e309be381acc33c463b6bc55e3744e5c114 (diff)
gnu: tensorflow-lite: Update to 2.12.1.
* gnu/packages/algebra.scm (eigen-for-tensorflow-lite): Remove variable. * gnu/packages/machine-learning.scm (tensorflow-lite): Update to 2.12.1 [arguments]<configure-flags>: Turn on GPU and RUY use; Use cmake to find packages already in Guix as dependencies for absl-cpp, eigen, flatbuffer, neon2ssl, cpuinfo, ruy. [arguments]<phases>: Remove operations setting up absl-cpp, eigen, ruy, and neon2ssl as native inouts as now we use Guix's packages of these as dependencies. Do default build phase. Add steps to install C shared library and benchmark_model tool. [inputs]: Add cpuinfo, eigen, fp16, mesa-header, opencl, pthreadpool, ruy, vulkan and xnnpack as explicit inputs. [native-inputs]: Remove local setup of neon2ssl and ruy as we now use Guix's packages of these as explicit dependencies. * gnu/packages/serialization.scm (flatbuffers-next-shared): New variable, flatbuffers-next built with -fPIC as needed by tensorflow-lite. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index a717750c7b..b1ab755144 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1154,38 +1154,6 @@ features, and more.")
(substitute* "test/CMakeLists.txt"
(("ei_add_test\\(stddeque") "#")))))))))))
-(define-public eigen-for-tensorflow-lite
- ;; This commit was taken from
- ;; tensorflow/lite/tools/cmake/modules/eigen.cmake
- (let ((commit "d10b27fe37736d2944630ecd7557cefa95cf87c9")
- (revision "1"))
- (package (inherit eigen)
- (name "eigen-for-tensorflow-lite")
- (version (git-version "3.3.7" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/libeigen/eigen")
- (commit commit)))
- (sha256
- (base32
- "0v8a20cwvwmp3hw4275b37frw33v92z0mr8f4dn6y8k0rz92hrrf"))
- (file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- ;; Ther are test failures in the "unsupported" directory, but
- ;; maintainers say it's unsupported anyway, so just skip
- ;; them.
- '(begin
- (substitute* "unsupported/CMakeLists.txt"
- (("add_subdirectory\\(test.*")
- "# Do not build the tests for unsupported features.\n"))))))
- (arguments
- (substitute-keyword-arguments (package-arguments eigen)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'disable-some-tests))))))))
-
(define-public xtensor
(package
(name "xtensor")