summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-01-25 14:45:43 +0100
committerAndreas Enge <andreas@enge.fr>2024-01-26 10:09:35 +0100
commitcdf1d7dded027019f0ebbd5d6f0147b13dfdd28d (patch)
tree048f2bba2740b46ea3adc0e1d08c1c9eeedf8b67 /gnu/packages/algebra.scm
parentff9d8420cf8bf0b0f0ceb4210966f821a0447858 (diff)
gnu: arb: Deprecate package.
* gnu/packages/algebra.scm (arb): Deprecate in favor of flint, of which it is now a part. Change-Id: I02ee2110e77c582b8daf70502f7092eba7c44547
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm42
1 files changed, 1 insertions, 41 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 5fd8d0f106..667a5f1a38 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -449,47 +449,7 @@ fast arithmetic.")
'((release-monitoring-url . "http://flintlib.org/downloads.html")))))
(define-public arb
- (package
- (name "arb")
- (version "2.23.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fredrik-johansson/arb")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1m9vskyf857gbm0cbh3z8c8m6cqkqa765wb9hqmsv7yzfmklzpvn"))))
- (build-system gnu-build-system)
- (propagated-inputs
- (list flint)) ; flint.h is included by arf.h
- (inputs
- (list gmp mpfr))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (flint (assoc-ref inputs "flint"))
- (gmp (assoc-ref inputs "gmp"))
- (mpfr (assoc-ref inputs "mpfr")))
- ;; Do not pass "--enable-fast-install", which makes the
- ;; homebrew configure process fail.
- (invoke "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-flint=" flint)
- (string-append "--with-gmp=" gmp)
- (string-append "--with-mpfr=" mpfr))))))))
- (home-page "https://arblib.org")
- (synopsis "Arbitrary precision floating-point ball arithmetic")
- (description
- "Arb is a C library for arbitrary-precision floating-point ball
-arithmetic. It supports efficient high-precision computation with
-polynomials, power series, matrices and special functions over the
-real and complex numbers, with automatic, rigorous error control.")
- (license license:lgpl2.1+)))
+ (deprecated-package "arb" flint))
(define-public python-flint
(package