summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2024-01-25 14:41:30 +0100
committerAndreas Enge <andreas@enge.fr>2024-01-26 10:09:35 +0100
commitff9d8420cf8bf0b0f0ceb4210966f821a0447858 (patch)
tree05b9976768dd893de3245116295b36edafe3e087 /gnu/packages/algebra.scm
parentf027a6c22c6cefe10cdd46821168bc9261111d5b (diff)
gnu: python-flint: Update to 0.5.0 and build with flint@3.
* gnu/packages/patches/python-flint-includes.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Unregister file. * gnu/packages/algebra.scm (python-flint): Update to 0.5.0. [source]: Drop patch. [inputs]: Drop arb. [native-inputs]: Use python-cython-3. Change-Id: I5fa9b201efff76e16f957aee0ebcd453ea823e69
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 43047a9b32..5fd8d0f106 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -494,7 +494,7 @@ real and complex numbers, with automatic, rigorous error control.")
(define-public python-flint
(package
(name "python-flint")
- (version "0.3.0")
+ (version "0.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -503,15 +503,14 @@ real and complex numbers, with automatic, rigorous error control.")
(file-name (git-file-name name version))
(sha256
(base32
- "1v0anazbj1cfi68nl2j6dbd31kgkc1563xmr0zk5xk3xj78569pw"))
- (patches (search-patches "python-flint-includes.patch"))))
+ "10370kqik6q6vdqrqv3gbznsyaxbgqb3rbrff4alpw0sqr5s07c7"))))
(build-system python-build-system)
(native-inputs
- (list python-cython))
+ (list python-cython-3))
(propagated-inputs
(list python-numpy))
(inputs
- (list arb flint))
+ (list flint))
(synopsis "Python module wrapping ARB and FLINT")
(description
"Python-flint is a Python extension module wrapping FLINT