summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 16:21:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-18 16:40:31 +0200
commit8cd80a4b61962c001bcaf7f3deb10bca88bf22f3 (patch)
treee8e71a11d9c58a80cc688938057f6d19eb47d72a /gnu/packages/algebra.scm
parentfbe9c80fb7a811914d0c6e66867c34e1ff70aae9 (diff)
gnu: eigen: Update to 3.3.5.
* gnu/packages/algebra.scm (eigen): Update to 3.3.5. [source]: Remove upstreamed ARM patch and obsolete substitutions. * gnu/packages/patches/eigen-arm-neon-fixes.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index a58ad84488..bb5c80b31a 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -697,16 +697,15 @@ Sine Transform} (DST) and @dfn{Discrete Hartley Transform} (DHT).")
(define-public eigen
(package
(name "eigen")
- (version "3.3.4")
+ (version "3.3.5")
(source (origin
(method url-fetch)
(uri (string-append "https://bitbucket.org/eigen/eigen/get/"
version ".tar.bz2"))
(sha256
(base32
- "19m4406jvqnwh7kpcvx1lfx2vdc5zwia5q9ayv89bimg1gmln9fx"))
+ "1qh3yrwn78ms5yhwbpl5wvblk4gbz02cacdygxylr7i9xbrvylkk"))
(file-name (string-append name "-" version ".tar.bz2"))
- (patches (search-patches "eigen-arm-neon-fixes.patch"))
(modules '((guix build utils)))
(snippet
;; There are 3 test failures in the "unsupported" directory,
@@ -716,16 +715,6 @@ Sine Transform} (DST) and @dfn{Discrete Hartley Transform} (DHT).")
(substitute* "unsupported/CMakeLists.txt"
(("add_subdirectory\\(test.*")
"# Do not build the tests for unsupported features.\n"))
- (substitute* "CMakeLists.txt"
- ;; Work around
- ;; <http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1114>.
- (("\"include/eigen3\"")
- "\"${CMAKE_INSTALL_PREFIX}/include/eigen3\""))
- (substitute* "test/bdcsvd.cpp"
- ;; See
- ;; https://bitbucket.org/eigen/eigen/commits/ea8c22ce6920e982d15245ee41d0531a46a28e5d
- ((".*svd_preallocate[^\n]*" &)
- (string-append "//" & " // Not supported by BDCSVD")))
#t))))
(build-system cmake-build-system)
(arguments