summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorMiguel Ángel Moreno <mail@migalmoreno.com>2024-02-11 21:38:21 +0100
committerLudovic Courtès <ludo@gnu.org>2024-02-18 15:56:05 +0100
commite47d3c6f945108b42d4ba0950f4076c07f246c45 (patch)
tree07d4d0730b4790b4eec714c77527ae74967dcc14 /gnu/packages/android.scm
parent8b7e0c195237f311608cd40c866848b76476c6d3 (diff)
gnu: Add emacs-fdroid.
* gnu/packages/android.scm (emacs-fdroid): New variable. Change-Id: I68358b5490406aa6ee24391bee6e69bebc574d96 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index e427628db3..902bc31faf 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -36,6 +36,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system android-ndk)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system emacs)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
@@ -1224,6 +1225,36 @@ connected devices via ADB.")
(home-page "https://github.com/mvdan/fdroidcl")
(license license:bsd-3)))
+(define-public emacs-fdroid
+ (package
+ (name "emacs-fdroid")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/migalmoreno/fdroid.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gv4kfir12bbi17cm5hpx197m8dbw1xwqp0z6qb3vc0fdnyis35j"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "fdroid.el"
+ ("fdroid-program"
+ (search-input-file inputs "/bin/fdroidcl"))))))))
+ (inputs (list fdroidcl))
+ (home-page "https://github.com/migalmoreno/fdroid.el")
+ (synopsis "Manage F-Droid packages from Emacs")
+ (description "This package is an Emacs interface to F-Droid. Its purpose
+is to aid in the management of F-Droid packages for an Android device or an
+emulator inside the comfort of Emacs.")
+ (license license:gpl3+)))
+
(define-public enjarify
(package
(name "enjarify")