summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-23 17:01:07 -0500
committerMark H Weaver <mhw@netris.org>2018-01-23 17:01:07 -0500
commita102d359a68ce7219a1880e47dd6f9332cbbce3a (patch)
treed879e718f08d776ad84c456c91a349e59941d1f2 /gnu/packages/android.scm
parent07b8ea841e1e2eda5b367f35cf68d23d0520cc4d (diff)
parentf3a13a21e50fa3751fc39e5768ea6843bfc19df2 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm66
1 files changed, 65 insertions, 1 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index ed71077d5e..6baefbca96 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -24,6 +24,7 @@
(define-module (gnu packages android)
#:use-module (guix packages)
+ #:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -35,7 +36,8 @@
#:use-module (gnu packages python)
#:use-module (gnu packages ssh)
#:use-module (gnu packages version-control)
- #:use-module (gnu packages tls))
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages linux))
;; The Makefiles that we add are largely based on the Debian
;; packages. They are licensed under GPL-2 and have copyright:
@@ -309,6 +311,33 @@ of device actions, such as installing and debugging apps, and it provides access
to a Unix shell that can run commands on the connected device or emulator.")
(license license:asl2.0)))
+(define-public mkbootimg
+ (package
+ (name "mkbootimg")
+ (version (android-platform-version))
+ (source (origin
+ (inherit (android-platform-system-core version))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-source
+ (lambda _ (chdir "mkbootimg") #t))
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "mkbootimg" bin)
+ #t))))))
+ (home-page "https://developer.android.com/studio/command-line/adb.html")
+ (synopsis "Tool to create Android boot images")
+ (description "This package provides a tool to create Android Boot
+Images.")
+ (license license:asl2.0)))
+
(define-public android-udev-rules
(package
(name "android-udev-rules")
@@ -439,3 +468,38 @@ parts of the development workflow. Repo is not meant to replace Git, only to
make it easier to work with Git. The repo command is an executable Python
script that you can put anywhere in your path.")
(license license:asl2.0)))
+
+(define-public abootimg
+ (package
+ (name "abootimg")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://http.debian.net/debian/pool/main/a/abootimg/"
+ "abootimg_" version ".orig.tar.gz"))
+ (sha256
+ (base32 "0sfc2k011l1ymv97821w89391gnqdh8pp0haz4sdcm5hx0axv2ba"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (setenv "CC" "gcc")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "abootimg" bin)
+ #t))))))
+ (inputs
+ `(("libblkid" ,util-linux)))
+ (home-page "https://ac100.grandou.net/abootimg")
+ (synopsis "Tool for manipulating Android Boot Images")
+ (description "This package provides a tool for manipulating old Android
+Boot Images. @code{abootimg} can work directly on block devices, or, the
+safest way, on a file image.")
+ (license license:gpl2+)))